The Sandbox Game (iPhone, iPad, Android, Amazon & PC Steam Versions) > Help / Support

Problem with restore a purchase

(1/2) > >>

What OS are you using ? Examples: IOS
What is the version of your OS ? iOS 7.0.6
What device are you using to play The Sandbox ? iPhone 5S
By what mean are you connected to the internet ? WiFi or 3G
I have a problem with restore a in app purchase : level pack
I can't restore it beacause when i press on restore purchase this do nothing
Can you fix it ? Or how i can do it work?
Thanks for the support

I'm having the same problem, except a couple of times I got the AppleID/Password box to come up and then I get a "Purchase Verification Failed" error. This happens on my iPhone 5s and iPapd 4. I bought the All Campaign Pack back when it was around $6 or $7. I'd really like to be able to have access to what I paid for.

Any help is appreciated.

Hi guys,

There is a work around to the "Restore Purchases" button not working. It's what I've been using for the last few version updates. If you have purchased a content pack before then simply tell the device to purchase it again. Don't worry when it asks you if you're sure you want to buy it and gives you a price, just confirm that and then another pop-up will, ahem, pop up, telling you that since you've purchased this before then it is free this time (and in the future).

Of course, this doesn't work for mana. IAPs can be divided in to two groups, consumables and non-consumables. Consumables are things like mana (in The Sandbox), donuts (in the Simpsons: Tapped Out), etc. Anything where you can use what you paid real money for in exchange for in-game items. Non-consumables are things like level packs, something that you can use multiple times after purchasing.

In the extremely rare event of it charging you a second time, you should get an e-mail receipt from Apple with a link on that you can follow to dispute the purchase and get refunded.

Thanks a lot for the suggestion, h0bd0b1in! I never thought of trying that. I had given up but since there was an update to the game today I figured I'd give it a try again. When I tried to restore my previous purchase, I got "Restoration Successful" within the game then a popup came up that said "Purchase Verification Failed."  I tried your suggestion of purchasing the All Campaign Pack again, which did produce a popup that said it would be free since I already purchased it. I continued with the transaction but none of the content was unlocked. I tried on both my iPhone and iPad and got the same results. This is really frustrating!

Kubaton, try signing out of the store, rebooting your device, and signing back in again, then try restore the IAP again. Also, make sure you don't have restrictions enabled that prevent you from making IAPs (I've seen an occasional bug that enables restrictions on a device during/after an OS update).

I did notice on the last update that this method didn't unlock the latest campaign (Sandmix Vol. 1) unless I removed and re-downloaded the game, but this obviously leads to you losing your save data so back that up using DiskAid if you can.


[0] Message Index

[#] Next page

Go to full version